The Spitfire Audio App

Follow

Comments

14 comments

  • Kuniyuki Takahashi

    I've just bought Studio Strings Professional, but the installing process won't even start.

    I think that this application has always been unstable to install.

    Please fix the problem of this bad application quickly.

    1
    Comment actions Permalink
  • Jack

    Hi Kuniyuki, I have created a support ticket on your behalf and someone will respond to it shortly to troubleshoot this with you. 

    Jack 

    0
    Comment actions Permalink
  • Kuniyuki Takahashi

    Hi Jack,

    After that, I still can not solve the problem, and no one can contact me.

    Plese help me!

    0
    Comment actions Permalink
  • Kuniyuki Takahashi

    The third day after purchasing the product, I continue downloading without rest, but it still does not end.
    I changed the download server as directed by the staff Luke, but at an incredibly slow download speed, I think there is a problem with the server but nothing is dealt with.
    What's going on?

    0
    Comment actions Permalink
  • Robert Gagnon

    Hello.  I had this problem some time ago; very very very long download time.  I discover that my antivirus was the cause.  If you have an antivirus installed, try to disable it when you want to download Spitfire sounds banks.

     

    0
    Comment actions Permalink
  • David Finnamore

    This is the only app I've ever seen that requires the user to sign in every time they open it. I'm having good success with the app, thankfully (Win10), but it's an unnecessary pain to have to log in every single time. I could possibly understand having to sign in again after restarting the computer, as I have to do with Avid's app manager, though even that is more than most apps require. But every time I run the app? Why?

    1
    Comment actions Permalink
  • Adrian Hannan

    Just updated the Spitfire Audio App and now it doesnt work. The new one may not be compatible with my old Mac Operating system 10. 10. 5

    0
    Comment actions Permalink
  • Matthew Knight

    Is there a way to download the library without using the app? 

    The app is incredibly slow for me, and only sometimes logs in. Then my products are either not displayed or I get a timeout error. I think the problem is with my internet (I have 4G broadband from Three, which maybe blocks some ports), so I can't see a way round.

    1
    Comment actions Permalink
  • dave thomas

    Hi, I am getting "The password was incorrect" error, but I can log into my account at Spitfire.com and obviously here too, thanks!

    0
    Comment actions Permalink
  • kin zo

    How anyone can confidently spend any real money on anything that relies on this app is beyond me.

    The first time I start up the app in a few weeks, and it wants an upgrade, with no option to defer to a later time... because of course! With that "upgrade" leaving the application unusable, the end result is that I'm here to download the installer to re-install the bloody thing again MANUALLY.

    Having re-installed the app, I'm beyond ecstatic to see that over two-thirds of the free content I previously installed is now under the "Not installed" category, even though they all still show in the LABS plugin in my DAW. Again, how anyone can throw real money at this stuff is a mystery to me. You may as well be building a palace on quick-sand.

    You might want to make that download link a bit more prominent, so it can be found more easily.

    1
    Comment actions Permalink
  • Angus

    Hi kin zo 

    I've created a ticket for you so that one of our agents can assist you and diagnose the issue with your system. Anyone else experiencing issues with the App should contact us directly using the Help widget below. We can then provide you directly with newer or older versions of the App, and log any issues with our engineering team. 

    All the best,

    Angus

    0
    Comment actions Permalink
  • Jim Johnson

    I seriously need some help. My 2012 MacBook Pro crashed and I've updated to a new Mac mini with the M1 chip.

    Luckily, I had all my spitfire libraries saved a separate SSD Drive. 

    All my Spitfire products requiring the Kontakt player work fine. But neither the BBC Core nor the Abbey Road apps will work. I am trying to relocate the plugins to the Library on my new hard drive but no matter what I do the new location is not being recognized. 

    Help!

    Jim

    0
    Comment actions Permalink
  • Trevian Strong

    How do I delete plugins from the app? I removed their actual files from the file location thinking the app would not show options for nonexistant files, but they still show as something that can be used... its not a terrible issue, but id like to know how to solve it all the same.

     

    0
    Comment actions Permalink
  • Dennis Munro

    i have lost all sounds and midi on a number of projects using labs ! please help. The spitfire audio app no longer opens at all. MacBook pro 2016 16g ram

    0
    Comment actions Permalink

Please sign in to leave a comment.