Spitfire Audio App - My download is not progressing!

Last updated:

 Reasons why your download may not progress:

 

  • This issue could be due to your firewall interrupting the download. Ensure you have your firewall turned off. 

 

  • This issue could also be because Anti-Malware Software is installed. If Anti-Malware Software is installed, try disabling it.

 

  • This issue could be due to a time out issue. It may be that at certain times of the day when traffic is particularly busy, your internet provider may throttle your connection speeds. We would advise you to leave your download running overnight as speeds should ramp up at less busy times. Should this continue, please contact support.

 

  • If you have changed country from where you first purchased the library, the IP Address is blocked. If you are using a VPN, try disabling it and if the issue persists please contact support.

  

 

Have more questions? Submit a request

Comments

  • Avatar
    Tom Hanna

    Hi i just purchased product of The Hans Zimmer Strings, i installed the software, but it gave a message says something went wrong, are you connected to the internet?
    i dont have a firewall or anti malware.
    please provide me help

    Edited by Tom Hanna
  • Avatar
    Jack

    Hi Tom,

    I have created a ticket on your behalf. Someone will be in touch shortly to troubleshoot this with you.

  • Avatar
    Tom Hanna

    Hi I have been waiting for more than half an hour,is there anybody will gonna contact me

  • Avatar
    Ivan Borcin

    Hi all, I have issues downloadig Soft Paino from within the App. Immediately after I click on DOWNLOAD, the app crashes (message “Program stopped working”). The version of the App is up-to-date, Firewall is off. Any help? Thanks

  • Avatar
    Wai Wan

    I've been having similar problems downloading LABS instruments on OS10.12 and 10.13 - the download page freezes and no progress is shown on the download page. The Spitfire Audio App is the most current (I've tried re-installing it several times) and the firewall is off. Any advice would be much appreciated. Thanks

  • Avatar
    Jake Moutarde

    Im having issues on Mac with all spitfire products. All the LABS are my test before I purchase and I cant get anything to work. I had soft piano on a while back and worked fine. Now its not working in Logic and says it needs repairing. Attempting to update as that is the only option and no downloads work. Stuck on 0%

    I then deleted everything from my system. And reinstalled the app and attempted download of LABS again. But nothing still.