How Can I Redownload a Product?

Follow

Comments

69 comments

  • Renzo Collins

    Is it possible to have Spitfire Labs instruments installed on two computers? Reason why I ask, is because on the second computer it shows as broken with no directory path. Not seeing an option to run another installation.

    2
    Comment actions Permalink
  • zijie Jin

    Hi, my friend.I need some help.Now I have successfully downloaded the woodwind and percussion parts of the BBCSO, but an attempt failed to download the string and brass parts.The reason seems to be that the reset times have been used up, as shown in the picture, could you please refresh the reset times for me to continue trying? Thank you!

    1
    Comment actions Permalink
  • Ben

    Hi Jan, you should be able to simply move the Hans Zimmer Strings plugin to the new plugin location. If you have any problems doing this, please use "chat" or "help" function in the bottom right of this page to speak to one of our support agents. You do not need to download the whole library again.

    1
    Comment actions Permalink
  • Manuel Lardizabal

    I've been trying to re-download London Contemporary Orchestra Strings but I have run out of times to reset the library. How can I get more resets?

    0
    Comment actions Permalink
  • RONALD BELL

    Ronald Bell Here I Nedd a new download for My Ericahitacre choir Please Asap

    0
    Comment actions Permalink
  • Ben

    Hi Lachlan. If you click on the product in the app and then look in the bottom right hand corner, you should see a "cog". Click on that and then "reset" to allow the download to happen.

    0
    Comment actions Permalink
  • Giacomo Sances

    I already wrote to your support, but no answer yet... I know it's Saturday: if you can't resolve it I'll wait for the next week. Thanks

    0
    Comment actions Permalink
  • Ben

    Giacomo, sorry about that. I looked at your account and according to our system, you don't own the library. It may be that the purchase is registered against a different account for some reason or your payment didn't go through. Do not worry, our support department will be able to get to the bottom of it for you.

    0
    Comment actions Permalink
  • Ben

    Pierre, I've created a ticket from your comment so one of our technicians can help.

    0
    Comment actions Permalink
  • Lachlan stuart

    Hello, I started a download of "frozen Strings" without an internet connection by accident. Now after regaining internet connection labs says that "Frozen Strings" is installed. However, this is not the case as I have checked the directories and there is no evidence of the pack being downloaded or installed. I have then attempted to reset the entire "Frozen Strings" library which resulted in a notification informing me that basically there is nothing to reset. I am still unable to "re-install" the pack even by clicking the website link to open Spitfire Labs and begin download, due to the fact that it thinks there is a pack installed when it is not.

    Any help would be greatly appreciated.

    (UPDATE)

    This has also happened with "Strings"

    0
    Comment actions Permalink
  • Jan Holy

    Hello to everyone. After upgrading Cubase 9.5 to Cubase 10 Pro, the VST Plug-in Manager has been reorganized. As a result, HZ Strings is out of work. I tried "reset" from Spitfire Manager, but without success. The "Instal" menu appears in "My Products" in the HZ Strings folder.
    Why should I download and reinstall? I have already downloaded and installed HZStrings .... and everything was fully functional. Thank you for answer Jan Holý

    0
    Comment actions Permalink
  • Moritz Freise

    Good Morning, because i thought "Albion ONE" would replace "Albion - VOLUME I"
    i erased the whole VOLUME I... *unfortunately i was wrong*
    Please be so kind and let me download the entire VOLUME I content ( was not able to do it via the Spitfire Audio Library Manager )

    Best Regards

    Moritz

    0
    Comment actions Permalink
  • Dor Friedman

    Hello Ben,
    I’ve just purchased the Studio Strings, and after hours of expectation after downloading the 210GB library, it show after I pressing the instrument, the Missing samples error..
    And I did I think the whole steps you instructed in the email message after purchasing.
    I already created a ticket , but yet nobody from spitfire support return in message..

    0
    Comment actions Permalink
  • Stephen MacLachlan

    Is there a way to upgrade from Albion Volume 1 to Albion One?

    0
    Comment actions Permalink
  • Ben

    Hi Giacomo. You can click on the library in the app and then click on the "cog" in the bottom right and choose "reset", this will enable you to download it again. Any problems and contact support at spitfireaudio.com/support

    0
    Comment actions Permalink
  • Giacomo Sances

    Hi, I bought HZ percussion and I have my serial number. The problem is that I can't find my library and I'd like to download it again. Could you help me?

    0
    Comment actions Permalink
  • Ben

    Manuel, you can get more resets by contacting out support team at spitfireaudio.com/support. Don't worry though, I'm doing this on your behalf.

    0
    Comment actions Permalink
  • Dan Goodchild

    Have been trying to download products and keep hitting a wall after a little while. A few gigs? Have been attempting to download Albion One and the speed drops down to less than 100kbs. Yes Kbs! It has basically stopped at 12.4 GB and just trickles in after that. HELP!!!

    0
    Comment actions Permalink
  • Andrew Bruhacs

    Hi Ben,

      here is my error log:

    https://www.dropbox.com/s/5znlihoyzd3z0q2/spitfireaudio2019-11-08_14-00-22.log?dl=0

    As you said, I will need to repair all the LABS instruments and then it should work. The error comes up only from the instruments that I haven't yet repaired fully. I just wish it would not have to redownload all the sample content.

    Let me know if you have any further advice. Thanks!

    0
    Comment actions Permalink
  • Ben

    Hi Alan, you don't actually need to "uninstall" from the previous computer, just follow the instructions above on the new one.

    0
    Comment actions Permalink
  • Ben

    Hi Paul, the easiest thing to do is to transfer the library contents over to the second computer on an external drive, however, if you open the Spitfire Audio App on the second computer, you can click on the library in question and then use the small "cog" icon in the bottom right to reset the library and allow you to download it a second time.

    0
    Comment actions Permalink
  • Matt Cohen

    Hello,

     

    I've reset Albion One Orchestra too many times and would appreciate if I could receive authorization to download it once again. I accidentally deleted some important files from my DAW and Spitfire Audio will not run now.

    Thanks,

     

     

    0
    Comment actions Permalink
  • William McNeil

    Hi, I've recently purchased a new mac. My original purchase of HZ Piano was provided on external drive by Spitfire. I've since mislaid the external drive and have no access to the original files. When following instruction to reset the entire library on library app, I get a message saying I can only reset latest installed version or newest available update. I'm not sure how to proceed. If I reset latest update will the app install the entire library again? Thanks

    0
    Comment actions Permalink
  • Josh Schroeder

    Hi there, I emailed support this morning about an issue I'm having re-installing BBC Discover. I had it working very well a few days ago until I upgraded my 2015 MacBook Pro to Catalina (BIG mistake).

    I downgraded back to Mojave with a clean install and now I can't seem to get BBC Discover installed again. I've tried downloading/installing from the Spitfire App several times and moving it to several different locations to see if I can get it to work but no luck.

    I was able to download/install Entropy and 2 of the LABS libraries, so I know I'm not going completely mad!?

    Any chance I can get some support on this? 

    Thanks so much!

    0
    Comment actions Permalink
  • Ben

    Anthony, if you haven't already please contact our support team by clicking on the "help" bubble in the bottom right of this page, this is a known issue on certain systems that we have a workaround for.

    0
    Comment actions Permalink
  • Ben

    Hi Stephen, yes, if you own Albion 1 and put Albion ONE in your cart, you should see a discount automatically applied.
    Ben

    0
    Comment actions Permalink
  • Ben

    It does include the latest update Richard.

    0
    Comment actions Permalink
  • Andrew Bruhacs

    Hi, I have a question about the download process.

    I just purchased BBCSO on SSD and am awaiting shipment. Meanwhile I decided I want to get acquainted with the LABS products, so I installed the spitfire app on a machine that has a fast internet connection, then downloaded all LABS and copied the entire directory Spitfire Audio - LABS onto a USB3 key formatted as exFAT.

    I then copied those USB key contents onto my workstation at home and then installed the Spitfire App there. Even though I set up the source to be the correct one on the workstation SSD, it keeps on redownloading all the libraries! I am afraid it will do the same thing with the 500 GB BBCSO...I really want to avoid this. How?

    All the libraries are right there...I tried to use the 'locate' function, but it simply proceeds to download anyway.

    Something is not right. What do you suggest I do?

    0
    Comment actions Permalink
  • Pablo Gallardo Varela

    Hi! I've recently installed BBC Discover on a second Mac, but Logic doesn't recognize the library. I've tried installing Labs and I can use them with no issues, but I can't find Discover on my instruments, neither in the module manager. I would appreciate any help.

    Muchas gracias!

    0
    Comment actions Permalink
  • Renan GERODOLLE

    Hi Ben,
    My alternative solo strings doesn't work : I've been reseting and re downloading it twice, on the advices of Luke from spitfire assistance... He sent me a new instruments folder...
    But as the library appears correctly "installed", I can't use the instruments, the message is the same for any of them :
    "Cello.nki" could not be loaded.
    The file format is not supported or corrupt.
    Please help ! Thx

    0
    Comment actions Permalink

Please sign in to leave a comment.