Telephone (US) +1 650-900-2039
Telephone (UK) +44 203 870 3205

How do I download products on Mac OSX 10.6.8 or lower?

Last updated:

Our Library Manager only supports Mac OSX 10.7 and upwards.

If you do not have a system with 10.7 upwards installed, or do not wish to update your system there is a way of creating an external boot drive that will work with our downloader. 

More information is available HERE

Alternatively, you can download the library to any other Mac or PC that is compatible with the Library Manager and then simply copy everything over to your own machine. We suggest doing this via an External Hard drive. 

Have more questions? Submit a request

Comments